Tom Joseph | fddc405 | 2017-01-16 16:43:05 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Network IPMI Daemon" |
| 2 | DESCRIPTION = "Daemon to support IPMI protocol over network" |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid" |
| 4 | PR = "r1" |
Patrick Venture | 6ffd6b4 | 2018-10-01 20:54:34 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Patrick Venture | 367b85b | 2018-11-03 09:43:10 -0700 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Tom Joseph | fddc405 | 2017-01-16 16:43:05 +0530 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Vernon Mauery | e46895b | 2019-03-22 12:25:14 -0700 | [diff] [blame] | 10 | inherit systemd |
Tom Joseph | fddc405 | 2017-01-16 16:43:05 +0530 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
Vernon Mauery | a1e96ee | 2019-04-12 14:06:06 -0700 | [diff] [blame] | 13 | DEPENDS += "cli11" |
Tom Joseph | fddc405 | 2017-01-16 16:43:05 +0530 | [diff] [blame] | 14 | DEPENDS += "phosphor-mapper" |
| 15 | DEPENDS += "systemd" |
| 16 | DEPENDS += "phosphor-ipmi-host" |
Tom Joseph | fddc405 | 2017-01-16 16:43:05 +0530 | [diff] [blame] | 17 | |
| 18 | SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid" |
Andrew Geissler | 9762121 | 2020-02-19 17:31:11 +0000 | [diff] [blame] | 19 | SRCREV = "2555e2ec1c5bd6636eb67a1a2cdf6b8b567772c9" |
Tom Joseph | fddc405 | 2017-01-16 16:43:05 +0530 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
Vernon Mauery | e46895b | 2019-03-22 12:25:14 -0700 | [diff] [blame] | 23 | FILES_${PN} += " \ |
| 24 | ${systemd_system_unitdir}/${PN}@.service \ |
| 25 | ${systemd_system_unitdir}/${PN}@.socket \ |
Tom Joseph | 1279869 | 2017-01-27 14:11:58 +0530 | [diff] [blame] | 26 | " |
Vernon Mauery | e46895b | 2019-03-22 12:25:14 -0700 | [diff] [blame] | 27 | |
| 28 | # If RMCPP_IFACE is not set by bbappend, set it to default |
| 29 | DEFAULT_RMCPP_IFACE = "eth0" |
| 30 | RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}" |
| 31 | |
| 32 | # install parameterized service and socket files |
| 33 | SYSTEMD_SERVICE_${PN} = " \ |
| 34 | ${PN}@${RMCPP_IFACE}.service \ |
| 35 | ${PN}@${RMCPP_IFACE}.socket \ |
| 36 | " |
| 37 | |
| 38 | # To add another RMCPP interface, add similar lines to the |
| 39 | # following lines in a bbappend: |
| 40 | # |
| 41 | # ALT_RMCPP_IFACE = "eth1" |
| 42 | # SYSTEMD_SERVICE_${PN} += " \ |
| 43 | # ${PN}@${ALT_RMCPP_IFACE}.service \ |
| 44 | # ${PN}@${ALT_RMCPP_IFACE}.socket \ |
| 45 | # " |
| 46 | |
| 47 | # Also, be sure to enable a corresponding entry in the channel |
| 48 | # config file with the same 'name' as the interfaces above |
| 49 | # Override the default phosphor-ipmi-config.bb with a bbappend |
| 50 | |