Vijay Khemka | 28c1697 | 2019-12-16 17:48:02 -0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor post code manager" |
| 2 | DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \ |
| 3 | interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \ |
| 4 | in a file under /var/lib for history." |
| 5 | |
| 6 | SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git" |
| 7 | SRCREV = "655837973feb51da3767f5f246ec198877900b0b" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | PV = "1.0+git${SRCPV}" |
| 12 | |
| 13 | LICENSE = "Apache-2.0" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 15 | |
| 16 | inherit cmake pkgconfig systemd |
| 17 | |
| 18 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.State.Boot.PostCode.service" |
| 19 | |
| 20 | DEPENDS += " \ |
| 21 | sdbusplus \ |
| 22 | phosphor-dbus-interfaces \ |
| 23 | phosphor-logging \ |
| 24 | " |