blob: 375e38620cb38db4c8745f297f1aa0e608fa770c [file] [log] [blame]
Brad Bishop7ee71462016-08-19 09:02:54 -05001SUMMARY = "OpenBMC - IPMI providers"
2PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-license
6
7PROVIDES = "${PACKAGES}"
8PACKAGES = "${PN}-libs"
9
Tom Josephf07ae012017-02-20 12:01:43 +053010OBMC_IPMID_PROVIDERS = "phosphor-ipmi-fru"
11
Brad Bishop7ee71462016-08-19 09:02:54 -050012SUMMARY_${PN}-libs = "Extra providers for ipmid."
Tom Josephf07ae012017-02-20 12:01:43 +053013RDEPENDS_${PN}-libs = "${OBMC_IPMID_PROVIDERS}"
14
15WHITELIST_FORMAT = "{0}-whitelist-native"
16OBMC_IPMID_WHITELISTS = "${@compose_list(d, 'WHITELIST_FORMAT', 'OBMC_IPMID_PROVIDERS')}"
17
Tom Josephdb48cb42017-02-24 01:06:54 -060018DEPENDS_append = "${OBMC_IPMID_WHITELISTS}"
19
20# Normally the dependency is between do_configure and
21# DEPENDS:do_populate_sysroot, but when a package is in the SSTATE cache the
22# do_configure step is not re-ran. The do_populate_sysroot tasks can themselves
23# be performed in parallel by bitbake.
24# Since the do_populate_sysroot task of this recipe doesn't provide the
25# whitelists itself, we need an explicit dependency on the whitelist's
26# do_populate_sysroot task so that the whitelists are present in time for an
27# application that needs them to be do_configured.
28
29WHITELIST_TASK_FORMAT = "{0}:do_populate_sysroot"
30do_populate_sysroot[depends] = "${@compose_list(d, 'WHITELIST_TASK_FORMAT', 'OBMC_IPMID_WHITELISTS')}"