Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for dbus applications using c. |
2 | |||||
3 | inherit obmc-phosphor-systemd | ||||
4 | inherit obmc-phosphor-license | ||||
5 | |||||
6 | DEPENDS += "glib-2.0" | ||||
7 | SRC_URI += " \ | ||||
8 | file://Makefile \ | ||||
9 | file://${PN}.c \ | ||||
10 | " | ||||
11 | S = "${WORKDIR}" | ||||
12 | |||||
13 | do_install_append() { | ||||
14 | # install the binary | ||||
15 | install -d ${D}${sbindir} | ||||
16 | install -m 0755 ${WORKDIR}/${PN} ${D}${sbindir} | ||||
17 | } |