blob: 1842697e3d19af3456fe2221af985fd05a608bbc [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
2DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
Sergey Solomin7df19362016-11-28 15:03:24 -06008PROVIDES += "virtual/obmc-host-ctl"
9RPROVIDES_${PN} += "virtual-obmc-host-ctl"
10
Brad Bishop86ee1cf2016-06-27 14:53:52 -040011SKELETON_DIR = "op-hostctl"
Brad Bishop0fe80462016-08-17 20:27:37 -040012
13FMT = "org.openbmc.control.Host@{0}.service"
14DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
Andrew Geissler3a206592017-03-23 12:48:06 -050015SYSTEMD_SERVICE_${PN} = " \
16 op-start-host@.service \
Andrew Geissler25875e32017-05-11 09:54:04 -050017 op-init-pnor@.service \
Andrew Geissler3a206592017-03-23 12:48:06 -050018 "
Brad Bishop0fe80462016-08-17 20:27:37 -040019
20START_TMPL = "op-start-host@.service"
Josh D. Kinga283e072017-04-06 15:56:37 -050021START_TGTFMT = "obmc-host-start@{1}.target"
Brad Bishop0fe80462016-08-17 20:27:37 -040022START_INSTFMT = "obmc-start-host@{0}.service"
Andrew Geisslera31fba52017-02-08 15:54:25 -060023START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
Brad Bishop0fe80462016-08-17 20:27:37 -040024
Andrew Geissler25875e32017-05-11 09:54:04 -050025INIT_PNOR_TMPL = "op-init-pnor@.service"
26INIT_PNOR_INSTFMT = "op-init-pnor@{0}.service"
27INIT_PNOR_FMT = "../${INIT_PNOR_TMPL}:${START_TGTFMT}.requires/${INIT_PNOR_INSTFMT}"
28
Brad Bishop0fe80462016-08-17 20:27:37 -040029SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
Andrew Geissler25875e32017-05-11 09:54:04 -050030SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'INIT_PNOR_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"