blob: 9e2f43f245bf176eb525bb98000bce9d20a1e9f3 [file] [log] [blame]
Brad Bishopf8a7cd12017-07-09 23:41:49 -04001SUMMARY = "Phosphor Mapper Configuration"
2DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
3configuration files to the native /usr/share/phosphor-mapper filesystem."
4HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
5PR = "r1"
6
7inherit obmc-phosphor-license
8inherit native
9inherit phosphor-mapper
10
11PHOSPHOR_MAPPER_CONFIGS = " \
12 phosphor-dbus-interfaces-mapper-config-native \
13 phosphor-legacy-namespace-mapper-config-native \
14 "
15
16DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
17
18# To add namespaces and blacklists to the mapper configuration,
19# create a native recipe in your layer, and add it to
20# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
21# Recipes should set one of the variables below.
22# Consult phosphor-mapper.bbclass for additional information.
23
24# Add path namespaces to be monitored.
25PHOSPHOR_MAPPER_NAMESPACE = ""
26
Brad Bishop385c63f2018-10-22 20:48:49 -040027# Add services to be monitored.
28PHOSPHOR_MAPPER_SERVICE = ""
29
Brad Bishopf8a7cd12017-07-09 23:41:49 -040030# Add interfaces to be monitored.
31PHOSPHOR_MAPPER_INTERFACE = ""
32
Brad Bishop385c63f2018-10-22 20:48:49 -040033# Blacklist services from being monitored.
34PHOSPHOR_MAPPER_SERVICE_BLACKLIST = ""
35
Brad Bishopf8a7cd12017-07-09 23:41:49 -040036do_install() {
37 install -d ${D}/${namespace_dir}
38 install -d ${D}/${interface_dir}
Brad Bishop385c63f2018-10-22 20:48:49 -040039 install -d ${D}/${serviceblacklist_dir}
Brad Bishopf8a7cd12017-07-09 23:41:49 -040040}