blob: 8b3b6ccc9f8d28186ead544c6f24e7261b2b2333 [file] [log] [blame]
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
Patrick Venturef0bb2a92019-03-07 10:51:53 -080016DEPENDS += "ipmi-blob-tool"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080017
18S = "${WORKDIR}/git"
19SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geissler9d0a30b2019-03-20 15:10:20 +000020SRCREV = "4679e50a5e19157b6bb4e4760a9fb92577ad37f5"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080021
22FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
24FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
25
26BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"