Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor ipmi tool for injecting ipmi commands" |
| 2 | DESCRIPTION = "IPMI Tool with dbus capabilities" |
| 3 | HOMEPAGE = "https://github.com/openbmc/ipmitool" |
| 4 | PR = "r1" |
| 5 | |
| 6 | |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 7 | inherit obmc-phosphor-license |
| 8 | |
| 9 | DEPENDS += "systemd \ |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 10 | host-ipmid \ |
| 11 | " |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 12 | |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 13 | RDEPENDS_${PN} += "libsystemd \ |
| 14 | libcrypto \ |
Brad Bishop | a6ec1d5 | 2016-09-08 17:09:18 -0400 | [diff] [blame] | 15 | virtual-obmc-host-ipmi-hw \ |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | |
| 19 | SRC_URI += "git://github.com/openbmc/ipmitool" |
| 20 | |
| 21 | SRCREV = "e9b9c1a9677a3de19726d036cfb07d8d61bbccd8" |
| 22 | |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | |
| 27 | do_compile() { |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 28 | ${S}/bootstrap --enable-intf-dbus |
| 29 | ${S}/configure --host x86_64 |
| 30 | make |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 31 | } |
| 32 | |
Brad Bishop | 1b8e41a | 2016-09-08 17:06:59 -0400 | [diff] [blame] | 33 | do_install() { |
| 34 | install -m 0755 -d ${D}${sbindir} |
| 35 | install -m 0755 ${S}/src/ipmitool ${D}${sbindir} |
Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 36 | } |