blob: 08e4d33a3164924bb9102c9548b47f3b63753cf1 [file] [log] [blame]
Adriana Kobylakfa7c2122015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishop5a4b9532015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
Brad Bishop5a4b9532015-10-21 20:24:23 -04009inherit obmc-phosphor-fan-mgmt
10inherit obmc-phosphor-flash-mgmt
11inherit obmc-phosphor-policy-mgmt
12inherit obmc-phosphor-sensor-mgmt
13inherit obmc-phosphor-system-mgmt
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040014
KennethWilke08c10892016-02-17 13:24:04 -060015DEPENDS += "glib-2.0 systemd"
Norman James83e4c042016-02-10 11:34:19 -060016RDEPENDS_${PN} += "python-subprocess python-compression libsystemd"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040017SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040018
Norman James90f124c2016-03-06 19:44:59 -060019SRCREV = "27ca44ad1a96f90d42dcb50183700e5ca5358642"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040020
Brad Bishopb264b812015-10-28 08:13:43 -050021S = "${WORKDIR}"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040022
23do_compile() {
Adriana Kobylak9bc34a42015-10-29 11:14:29 -050024 oe_runmake -C git
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040025}
26
27do_install() {
Brad Bishopb264b812015-10-28 08:13:43 -050028 source=${S}/git
29
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040030 install -d ${D}/${sbindir} ${D}${libdir}
Adriana Kobylak9bc34a42015-10-29 11:14:29 -050031 for i in ${source}/bin/*; do
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040032 install $i ${D}/${sbindir}
33 done
Adriana Kobylak9bc34a42015-10-29 11:14:29 -050034 for i in ${source}/lib/*; do
35 install $i ${D}/${libdir}
36 done
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040037}