blob: 57f36f10f5f2189742a6550593beb4effa43b948 [file] [log] [blame]
Adriana Kobylakfa7c2122015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishop5a4b9532015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
9inherit obmc-phosphor-event-mgmt
10inherit obmc-phosphor-fan-mgmt
11inherit obmc-phosphor-flash-mgmt
12inherit obmc-phosphor-policy-mgmt
13inherit obmc-phosphor-sensor-mgmt
14inherit obmc-phosphor-system-mgmt
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040015
16DEPENDS += "glib-2.0"
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040017RDEPENDS_${PN} += "python-subprocess python-tftpy"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040018SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040019
Brad Bishopfda794c2015-10-19 21:09:11 -040020SRCREV = "831188fedd74d86e137ec0c8e39c7395548ad480"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040021
22S = "${WORKDIR}/git"
23
24do_compile() {
25 oe_runmake all
26}
27
28do_install() {
29 install -d ${D}/${sbindir} ${D}${libdir}
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040030 for i in ${S}/bin/*.py ${S}/bin/*.exe; do
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040031 install $i ${D}/${sbindir}
32 done
33 install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
34}