blob: c6369b0d2e56d3a504a4315a02549d431492c626 [file] [log] [blame]
Adriana Kobylakfa7c2122015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8
9DEPENDS += "glib-2.0"
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040010RDEPENDS_${PN} += "python-subprocess python-tftpy"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040011SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040012
Brad Bishopfda794c2015-10-19 21:09:11 -040013SRCREV = "831188fedd74d86e137ec0c8e39c7395548ad480"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040014
15S = "${WORKDIR}/git"
16
17do_compile() {
18 oe_runmake all
19}
20
21do_install() {
22 install -d ${D}/${sbindir} ${D}${libdir}
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040023 for i in ${S}/bin/*.py ${S}/bin/*.exe; do
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040024 install $i ${D}/${sbindir}
25 done
26 install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
27}