Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC inventory manager" |
| 2 | DESCRIPTION = "OpenBMC inventory manager." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-python |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
Matt Spinler | 6f5fba1 | 2016-09-13 16:20:01 -0500 | [diff] [blame] | 8 | RRECOMMENDS_${PN} += "virtual-obmc-inventory-data" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 9 | |
| 10 | RDEPENDS_${PN} += "\ |
Adriana Kobylak | ca2b6a9 | 2016-08-26 09:39:39 -0500 | [diff] [blame] | 11 | python-argparse \ |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 12 | python-dbus \ |
| 13 | python-json \ |
| 14 | python-pickle \ |
| 15 | python-pygobject \ |
Adriana Kobylak | ca2b6a9 | 2016-08-26 09:39:39 -0500 | [diff] [blame] | 16 | python-subprocess \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 17 | pyphosphor-dbus \ |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 18 | ${VIRTUAL-RUNTIME_skeleton_workbook} \ |
| 19 | " |
| 20 | |
| 21 | SKELETON_DIR = "pyinventorymgr" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 22 | DBUS_SERVICE_${PN} += "org.openbmc.Inventory.service" |
| 23 | SYSTEMD_SERVICE_${PN} += "obmc-sync-inventory-item@.service" |