Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Linux kernel for OpenBMC" |
| 2 | SECTION = "kernel" |
| 3 | LICENSE = "GPLv2" |
| 4 | |
| 5 | KBRANCH ?= "dev" |
Brad Bishop | 7d3e4f3 | 2015-10-30 03:11:05 -0400 | [diff] [blame] | 6 | KCONFIG_MODE="--alldefconfig" |
Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}" |
Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 9 | |
| 10 | LINUX_VERSION ?= "4.2" |
Brad Bishop | 7d3e4f3 | 2015-10-30 03:11:05 -0400 | [diff] [blame] | 11 | LINUX_VERSION_EXTENSION ?= "-${SRCREV}" |
Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 12 | |
Jeremy Kerr | aed40b2 | 2015-11-04 17:50:40 +0800 | [diff] [blame] | 13 | SRCREV="openbmc-20151104-1" |
Brad Bishop | 4ccd9f3 | 2015-10-06 00:27:43 -0400 | [diff] [blame] | 14 | |
| 15 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 16 | |
| 17 | COMPATIBLE_MACHINE_${MACHINE} = "openbmc" |
| 18 | |
| 19 | inherit kernel |
| 20 | require recipes-kernel/linux/linux-yocto.inc |
Brad Bishop | 3a09565 | 2015-11-01 20:13:47 -0500 | [diff] [blame] | 21 | |
| 22 | do_patch_append() { |
| 23 | for DTB in "${KERNEL_DEVICETREE}"; do |
| 24 | DT=`basename ${DTB} .dtb` |
| 25 | if [ -r "${WORKDIR}/${DT}.dts" ]; then |
| 26 | cp ${WORKDIR}/${DT}.dts \ |
| 27 | ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts |
| 28 | fi |
| 29 | done |
| 30 | } |