Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor Fan Presence" |
| 2 | DESCRIPTION = "Phosphor fan presence provides a set of fan presence \ |
| 3 | daemons to monitor fan presence changes by different methods of \ |
| 4 | presence detection." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-fan-presence" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | inherit autotools pkgconfig pythonnative |
| 11 | inherit obmc-phosphor-systemd |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "python-pyyaml-native" |
| 15 | DEPENDS += "sdbusplus" |
| 16 | DEPENDS += "phosphor-logging" |
| 17 | RDEPENDS_${PN} += "sdbusplus" |
| 18 | |
| 19 | FAN_PRESENCE_PACKAGES = " \ |
| 20 | ${PN}-tach \ |
| 21 | " |
| 22 | PACKAGES_remove = "${PN}" |
| 23 | PACKAGES += "${FAN_PRESENCE_PACKAGES}" |
| 24 | SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}" |
| 25 | RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}" |
| 26 | |
| 27 | # Needed to install into the obmc-chassis-start target |
| 28 | TMPL = "phosphor-fan-presence-tach@.service" |
| 29 | INSTFMT = "phosphor-fan-presence-tach@{0}.service" |
| 30 | TGTFMT = "obmc-chassis-start@{0}.target" |
| 31 | FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}" |
| 32 | |
| 33 | FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach" |
| 34 | SYSTEMD_SERVICE_${PN}-tach += "${TMPL}" |
| 35 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 36 | |
| 37 | SRC_URI += "git://github.com/openbmc/phosphor-fan-presence" |
Patrick Williams | 721aefc | 2017-03-21 16:00:05 -0500 | [diff] [blame] | 38 | SRCREV = "14476ae2e627fcc5fe8390db08b957bcfc16b912" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 39 | |
| 40 | S = "${WORKDIR}/git" |