Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 1 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 2 | DEPENDS = "mtd-utils" |
| 3 | |
Brad Bishop | b3bbfa0 | 2018-02-16 20:54:07 -0500 | [diff] [blame] | 4 | require u-boot-common.inc |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 5 | |
| 6 | INSANE_SKIP_${PN} = "already-stripped" |
| 7 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| 8 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| 9 | |
| 10 | inherit uboot-config |
| 11 | |
| 12 | do_compile () { |
| 13 | oe_runmake ${UBOOT_MACHINE} |
| 14 | oe_runmake env |
| 15 | } |
| 16 | |
| 17 | do_install () { |
| 18 | install -d ${D}${base_sbindir} |
| 19 | install -d ${D}${sysconfdir} |
| 20 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv |
| 21 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv |
| 22 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config |
| 23 | } |
| 24 | |
| 25 | do_install_class-cross () { |
| 26 | install -d ${D}${bindir_cross} |
| 27 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv |
| 28 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv |
| 29 | } |
| 30 | |
Brad Bishop | b0628e4 | 2018-02-08 16:12:57 -0500 | [diff] [blame] | 31 | SYSROOT_DIRS_append_class-cross = " ${bindir_cross}" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 32 | |
| 33 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 34 | BBCLASSEXTEND = "cross" |