Jeremy Kerr | 49208ee | 2016-03-17 17:35:27 +0800 | [diff] [blame] | 1 | SUMMARY = "OpenBMC console daemon" |
| 2 | DESCRIPTION = "Daemon to handle UART console connections" |
| 3 | HOMEPAGE = "http://github.com/openbmc/obmc-console" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit obmc-phosphor-license |
| 7 | inherit obmc-phosphor-systemd |
| 8 | inherit autotools |
| 9 | |
| 10 | TARGET_CFLAGS += "-fpic -O2" |
| 11 | |
| 12 | SRC_URI += "git://github.com/openbmc/obmc-console" |
| 13 | SRC_URI += "file://${PN}.conf" |
| 14 | SRCREV = "54e9569d14b127806e45e1c17ec4a1f5f7271d3f" |
| 15 | |
| 16 | do_install_append() { |
| 17 | install -m 0755 -d ${D}${sysconfdir} |
| 18 | install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf |
| 19 | } |
| 20 | |
| 21 | S = "${WORKDIR}/git" |