blob: 05d5baa95215138542b96239e37b0106e5493d40 [file] [log] [blame]
Matt Spinler2332ef82016-08-25 13:04:09 -05001SUMMARY = "Phosphor machine readable workbook patching script"
2DESCRIPTION = "Retrieve the script that can patch the MRW XML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit obmc-phosphor-license
8inherit native
9
10DEPENDS += "python-native python-lxml-native"
11
12SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools"
Patrick Williamsa9feb8b2016-09-14 22:00:07 -050013SRCREV = "7a68567af7bf121143ef135152a39723518b6e06"
Matt Spinler2332ef82016-08-25 13:04:09 -050014
15do_install() {
Matt Spinler471b8852016-09-20 13:32:44 -050016 install -d ${D}${bindir}/obmc-mrw
17 install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw
Matt Spinler2332ef82016-08-25 13:04:09 -050018}