Ed Tanous | fe41c38 | 2019-01-11 16:26:13 -0800 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | DEPENDS += "systemd" |
| 4 | |
Vernon Mauery | c89d95e | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 5 | SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https" |
Vernon Mauery | 0b4708b | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 6 | SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901" |
Vernon Mauery | c89d95e | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 7 | |
Vernon Mauery | 0b4708b | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 8 | # TODO: when a new company joins the OpenBMC project by signing |
| 9 | # a CLA, if they have an enterprise number on file with the |
| 10 | # IANA, the versioned file, $PWD/ipmitool/enterprise-numbers |
| 11 | # needs to be updated to add their entry. The canonical |
| 12 | # version of the file is locatede here: |
| 13 | # https://www.iana.org/assignments/enterprise-numbers |
| 14 | # |
| 15 | # This file is manually downloaded so it can be versioned |
| 16 | # instead of having the makefile download it during do_compile |
Vernon Mauery | c89d95e | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 17 | SRC_URI += " \ |
Vernon Mauery | 0b4708b | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 18 | file://enterprise-numbers \ |
Vernon Mauery | c89d95e | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 19 | " |
| 20 | |
Vernon Mauery | 0b4708b | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 21 | # make sure that the enterprise-numbers file gets installed in the root FS |
| 22 | FILES_${PN} += "/usr/share/misc/enterprise-numbers" |
| 23 | do_compile_prepend() { |
| 24 | # copy the SRC_URI version of enterprise-numbers |
| 25 | # to the build dir to prevent a fetch |
| 26 | cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers" |
| 27 | } |
| 28 | |
Vernon Mauery | c89d95e | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 29 | S = "${WORKDIR}/git" |
| 30 | LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184" |
| 31 | |
Yong Li | 9bef780 | 2019-12-05 12:40:24 +0800 | [diff] [blame] | 32 | EXTRA_OECONF_append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus " |
Vernon Mauery | c89d95e | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 33 | |
| 34 | PV = "1.8.18+git${SRCPV}" |