blob: 8b97e62bf738013c0f9edee2ae4a7cf8b08572bb [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC system manager"
2DESCRIPTION = "OpenBMC system manager."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8VIRTUAL-RUNTIME_skeleton_workbook ?= ""
9
10RDEPENDS_${PN} += "\
11 python-dbus \
12 python-json \
13 python-subprocess \
14 python-pygobject \
Brad Bishop1b4e4472016-08-29 21:47:04 -040015 pyphosphor-dbus \
Brad Bishop86ee1cf2016-06-27 14:53:52 -040016 ${VIRTUAL-RUNTIME_skeleton_workbook} \
17 "
18
19SKELETON_DIR = "pysystemmgr"
20
21do_compile_append() {
22 oe_runmake -C ../hacks
23}
24
25do_install_append() {
26 oe_runmake -C ../hacks install DESTDIR=${D}
27}
Brad Bishop0fe80462016-08-17 20:27:37 -040028
29DBUS_SERVICE_${PN} += "org.openbmc.managers.System.service"
30SYSTEMD_SERVICE_${PN} += "startup-hacks.service"