blob: 56286123e86acf3d1ebe320c2f070e67acf4f34e [file] [log] [blame]
Matt Spinler23f28832016-09-07 13:39:18 -05001SUMMARY = "Phosphor Inventory Generation"
2DESCRIPTION = "Generates inventory data from the machine readable workbook"
3PR = "r1"
Patrick Venture77d14392018-10-30 17:17:07 -07004PV = "1.0+git${SRCPV}"
Patrick Ventureb8800572018-11-06 10:02:59 -08005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Matt Spinler23f28832016-09-07 13:39:18 -05007
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06008inherit mrw-xml
9
Matt Spinler23f28832016-09-07 13:39:18 -050010S = "${WORKDIR}/git"
11
Matt Spinler6f5fba12016-09-13 16:20:01 -050012PROVIDES += "virtual/obmc-inventory-data"
13RPROVIDES_${PN} += "virtual-obmc-inventory-data"
Matt Spinler23f28832016-09-07 13:39:18 -050014
15inherit allarch
Patrick Williamsd30c9292016-10-31 15:45:17 -050016inherit mrw-rev
Matt Spinler23f28832016-09-07 13:39:18 -050017
18DEPENDS += "mrw-native mrw-api-native"
19
Patrick Williams4f02a452016-10-31 15:46:40 -050020SRC_URI += "${MRW_TOOLS_SRC_URI}"
21SRCREV = "${MRW_TOOLS_SRCREV}"
Matt Spinler23f28832016-09-07 13:39:18 -050022
23FILES_${PN} += "${datadir}/inventory"
24
25do_compile() {
26 ${STAGING_BINDIR_NATIVE}/perl-native/perl ${S}/inventory.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060027 -x ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} -o inventory.json
Matt Spinler23f28832016-09-07 13:39:18 -050028}
29
30do_install() {
31 install -d ${D}${datadir}/inventory
32 install -m 0644 inventory.json ${D}${datadir}/inventory/inventory.json
33}