Brad Bishop | 30f7855 | 2017-01-28 12:51:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Sample inventory map for phosphor-ipmi-fru" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit phosphor-ipmi-fru |
| 6 | |
| 7 | require phosphor-ipmi-fru.inc |
| 8 | |
| 9 | PROVIDES += "virtual/phosphor-ipmi-fru-inventory" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | do_install() { |
Patrick Williams | 70a568d | 2017-02-09 12:20:09 -0600 | [diff] [blame] | 14 | # TODO: install this to inventory_datadir |
| 15 | # after ipmi-fru-parser untangles the host |
| 16 | # firmware config from the machine inventory. |
| 17 | DEST=${D}${config_datadir} |
Brad Bishop | 30f7855 | 2017-01-28 12:51:42 -0500 | [diff] [blame] | 18 | install -d ${DEST} |
Patrick Williams | 70a568d | 2017-02-09 12:20:09 -0600 | [diff] [blame] | 19 | install scripts/example.yaml ${DEST}/config.yaml |
Brad Bishop | 30f7855 | 2017-01-28 12:51:42 -0500 | [diff] [blame] | 20 | } |