blob: 37b27ac695e9c9c935615aa077fb595e879d0dad [file] [log] [blame]
Patrick Venturec8eec652017-04-10 15:21:32 -07001FILESEXTRAPATHS_append := "${THISDIR}/files:"
Patrick Venturecf534522018-11-06 09:40:06 -08002LICENSE = "Apache-2.0"
Brad Bishop170929b2019-09-13 13:04:22 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Patrick Venturec8eec652017-04-10 15:21:32 -07004
5inherit systemd
Patrick Venturec8eec652017-04-10 15:21:32 -07006inherit obmc-phosphor-systemd
7
8S = "${WORKDIR}/"
9
10SRC_URI = "file://init_once.sh \
11 file://poweroff.sh \
12 file://poweron.sh \
13 file://host-gpio.service \
14 file://host-poweroff.service \
15 file://host-poweron.service"
16
17DEPENDS = "systemd"
18RDEPENDS_${PN} = "bash"
19
20SYSTEMD_PACKAGES = "${PN}"
21SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
22
23do_install() {
Patrick Venture77c5f7a2019-04-10 07:34:36 -070024 install -d ${D}/${bindir}
25 install -m 0755 ${S}init_once.sh ${D}/${bindir}/
26 install -m 0755 ${S}poweroff.sh ${D}/${bindir}/
27 install -m 0755 ${S}poweron.sh ${D}/${bindir}/
Patrick Venturec8eec652017-04-10 15:21:32 -070028}