blob: fca483e11b62c9f61b13b7ac6d121193dd512f3d [file] [log] [blame]
AlanKuoa3107262020-11-02 09:35:28 +08001SUMMARY = "Enable TLS with static CA"
2DESCRIPTION = "Add static CA and only enable TLS authentication"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
7
8SRC_URI += "file://certs/authority/ \
9 file://bmcweb_persistent_data.json \
10 "
11do_install(){
12 install -d ${D}${sysconfdir}/ssl/certs/authority
13 install -m 0644 -D ${WORKDIR}/certs/authority/* \
14 ${D}${sysconfdir}/ssl/certs/authority
15
16 install -d ${D}${ROOT_HOME}
17 install -m 0640 ${WORKDIR}/bmcweb_persistent_data.json ${D}${ROOT_HOME}
18}
19
20FILES_${PN} = "${ROOT_HOME}/bmcweb_persistent_data.json \
21 ${sysconfdir}/ssl/certs/authority/* \
22 "