blob: 74785ef639c030d7695fe11cab80abb66fdb54e0 [file] [log] [blame]
George Hung09b8cd92020-06-04 19:54:41 +08001SUMMARY = "OpenBMC Quanta Detect SAS Cable Service"
2DESCRIPTION = "OpenBMC Quanta Detect SAS Cable Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12SRC_URI = " file://detect-sas-cable.sh \
13 file://detect-sas-cable.service \
14 "
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/detect-sas-cable.sh ${D}${bindir}/
19
20 install -d ${D}${systemd_system_unitdir}
21 install -m 0644 ${WORKDIR}/detect-sas-cable.service ${D}${systemd_system_unitdir}
22}
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "detect-sas-cable.service"