blob: 647633f615bc6d68958dbab36e8eef88dd8088f3 [file] [log] [blame]
Patrick Venture76428942017-05-09 10:04:13 -07001SUMMARY = "Quanta Q71l board wiring"
2DESCRIPTION = "Board wiring information for the Quanta Q71l system."
3PR = "r1"
4
5inherit allarch
6inherit setuptools
7inherit pythonnative
8inherit obmc-phosphor-license
9
10PROVIDES += "virtual/obmc-inventory-data"
11RPROVIDES_${PN} += "virtual-obmc-inventory-data"
12
13DEPENDS += "python"
14
15S = "${WORKDIR}"
16SRC_URI += "file://Quanta-q71l.py"
17
18# the following is unnecessary.
19python() {
20 machine = d.getVar('MACHINE', True).capitalize() + '.py'
21 d.setVar('_config_in_skeleton', machine)
22}
23
24do_make_setup() {
25 cp ${S}/${_config_in_skeleton} \
26 ${S}/obmc_system_config.py
27 cat <<EOF > ${S}/setup.py
28from distutils.core import setup
29
30setup(name='${BPN}',
31 version='${PR}',
32 py_modules=['obmc_system_config'],
33 )
34EOF
35}
36
37addtask make_setup after do_patch before do_configure