blob: 83bf5c2b2eeefcbb02a5b931595d8692928ca87d [file] [log] [blame]
Patrick Venture864fa492018-11-05 20:48:03 -08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
3
Patrick Venture44b67f52018-04-13 13:41:52 -07004inherit native
Patrick Venture44b67f52018-04-13 13:41:52 -07005
6DEPENDS += "virtual/phosphor-ipmi-fru-inventory"
7PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
8
9# Put the fru_config in the right place with the right name.
10# Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML.
11do_install_append() {
12 IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config
13 IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config
14 install -d ${IPMI_HOST_DEST}
15 cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml
16}