Duke Du | 94311c5 | 2019-05-29 09:19:24 +0800 | [diff] [blame] | 1 | SUMMARY = "OpenBMC Quanta Detect Fan Fail Service" |
| 2 | DESCRIPTION = "OpenBMC Quanta Detect Fan Fail Daemon." |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
Brad Bishop | 170929b | 2019-09-13 13:04:22 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Duke Du | 94311c5 | 2019-05-29 09:19:24 +0800 | [diff] [blame] | 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
| 10 | RDEPENDS_${PN} += "bash" |
| 11 | |
| 12 | FILESEXTRAPATHS_append_gsj := "${THISDIR}/files:" |
| 13 | SRC_URI_append_gsj = " file://detect-fan-fail.sh \ |
| 14 | file://detect-fan-fail.service \ |
| 15 | " |
| 16 | |
| 17 | do_install_append_gsj() { |
| 18 | install -d ${D}${bindir} |
| 19 | install -m 0755 ${WORKDIR}/detect-fan-fail.sh ${D}${bindir}/ |
| 20 | |
| 21 | install -d ${D}${systemd_unitdir}/system/ |
| 22 | install -m 0644 ${WORKDIR}/detect-fan-fail.service ${D}${systemd_unitdir}/system |
| 23 | } |
| 24 | |
| 25 | SYSTEMD_PACKAGES = "${PN}" |
| 26 | SYSTEMD_SERVICE_${PN} = "detect-fan-fail.service" |