George Hung | 41dd147 | 2020-06-11 21:11:09 +0800 | [diff] [blame] | 1 | SUMMARY = "NVMe Drives Power Control" |
| 2 | DESCRIPTION = "Daemon to monitor and control the power of NVMe drives" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit meson pkgconfig |
| 8 | inherit systemd |
| 9 | |
| 10 | DEPENDS += "sdbusplus" |
| 11 | DEPENDS += "boost" |
| 12 | DEPENDS += "libgpiod" |
| 13 | |
| 14 | SRC_URI = "git://github.com/quanta-bmc/nvme-power-control;protocol=git" |
| 15 | SRCREV = "9bc98c2de5d9ae367e450a8acc4b6cf0c3a3dd63" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Control.Nvme.Power.service" |