Patrick Venture | c8eec65 | 2017-04-10 15:21:32 -0700 | [diff] [blame] | 1 | FILESEXTRAPATHS_append := "${THISDIR}/files:" |
Patrick Venture | cf53452 | 2018-11-06 09:40:06 -0800 | [diff] [blame] | 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Patrick Venture | c8eec65 | 2017-04-10 15:21:32 -0700 | [diff] [blame] | 4 | |
| 5 | inherit systemd |
Patrick Venture | c8eec65 | 2017-04-10 15:21:32 -0700 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
| 7 | |
| 8 | S = "${WORKDIR}/" |
| 9 | |
| 10 | SRC_URI = "file://init_once.sh \ |
| 11 | file://poweroff.sh \ |
| 12 | file://poweron.sh \ |
| 13 | file://host-gpio.service \ |
| 14 | file://host-poweroff.service \ |
| 15 | file://host-poweron.service" |
| 16 | |
| 17 | DEPENDS = "systemd" |
| 18 | RDEPENDS_${PN} = "bash" |
| 19 | |
| 20 | SYSTEMD_PACKAGES = "${PN}" |
| 21 | SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service" |
| 22 | |
| 23 | do_install() { |
Patrick Venture | 77c5f7a | 2019-04-10 07:34:36 -0700 | [diff] [blame] | 24 | install -d ${D}/${bindir} |
| 25 | install -m 0755 ${S}init_once.sh ${D}/${bindir}/ |
| 26 | install -m 0755 ${S}poweroff.sh ${D}/${bindir}/ |
| 27 | install -m 0755 ${S}poweron.sh ${D}/${bindir}/ |
Patrick Venture | c8eec65 | 2017-04-10 15:21:32 -0700 | [diff] [blame] | 28 | } |