George Hung | 3a9aa27 | 2020-06-19 19:45:43 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Quanta GBS System Initialization Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Quanta GBS System Init" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
| 10 | RDEPENDS_${PN} += "bash" |
| 11 | RDEPENDS_${PN} += "libsystemd" |
| 12 | RDEPENDS_${PN} += "jq" |
| 13 | |
| 14 | SRC_URI = "file://gbs-sysinit.sh \ |
| 15 | file://gbs-gpio-common.sh \ |
| 16 | file://gbs-sysinit.service \ |
| 17 | " |
| 18 | |
| 19 | do_install () { |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${WORKDIR}/gbs-sysinit.sh ${D}${bindir}/ |
| 22 | |
| 23 | install -d ${D}${libexecdir} |
| 24 | install -m 0755 ${WORKDIR}/gbs-gpio-common.sh ${D}${libexecdir}/ |
| 25 | |
| 26 | install -d ${D}${systemd_system_unitdir} |
| 27 | install -m 0644 ${WORKDIR}/gbs-sysinit.service ${D}${systemd_system_unitdir} |
| 28 | } |
| 29 | |
| 30 | SYSTEMD_PACKAGES = "${PN}" |
| 31 | SYSTEMD_SERVICE_${PN} = "gbs-sysinit.service" |