blob: 6bf7bb69ff47d7d184e024aa20dae0a7e736f8e4 [file] [log] [blame]
George Hung4f20ff82020-05-12 16:56:27 +08001SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
Brandon Kimf2714342020-08-12 19:15:12 -070012SRC_URI = " file://hotswap-power-cycle.service \
13 file://tray_powercycle.sh \
14 "
George Hung4f20ff82020-05-12 16:56:27 +080015
16do_install() {
17 install -d ${D}${systemd_system_unitdir}
18 install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir}
Brandon Kimf2714342020-08-12 19:15:12 -070019
20 install -d ${D}${bindir}
21 install -m 0755 ${WORKDIR}/tray_powercycle.sh ${D}${bindir}
George Hung4f20ff82020-05-12 16:56:27 +080022}
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "hotswap-power-cycle.service"
26