blob: e4cf77a1348852bebed0f9125da5ff357b25c2ef [file] [log] [blame]
SUMMARY = "MQTT version 3.1/3.1.1 client library"
LICENSE = "EPL-1.0 | EDL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \
file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
"
SRCNAME = "paho-mqtt"
inherit pypi python_hatchling python_setuptools_build_meta
SRC_URI[sha256sum] = "13b205f29251e4f2c66a6c923c31fc4fd780561e03b2d775cff8e4f2915cf947"
PYPI_SRC_URI = "https://files.pythonhosted.org/packages/73/b7/a4df0f93bbdae237e16ba402752151eceee576cbe80c235a2475fbf81eea/paho_mqtt-${PV}.tar.gz"
S = "${WORKDIR}/paho_mqtt-${PV}"
DEPENDS += "python3-pytest-runner-native"
do_install:append() {
install -d -m0755 ${D}${datadir}/${BPN}/examples
cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples
}
PACKAGES =+ "${PN}-examples"
RDEPENDS:${PN}-examples += "${PN} python3-core"
FILES:${PN}-examples = "${datadir}/${BPN}/examples"
RDEPENDS:${PN} = "\
python3-io \
python3-logging \
python3-math \
python3-netclient \
python3-threading \
"
BBCLASSEXTEND = "native nativesdk"