blob: e4cf77a1348852bebed0f9125da5ff357b25c2ef [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "MQTT version 3.1/3.1.1 client library"
2LICENSE = "EPL-1.0 | EDL-1.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \
4 file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
5"
6SRCNAME = "paho-mqtt"
7
Patrick Williams03514f12024-04-05 07:04:11 -05008inherit pypi python_hatchling python_setuptools_build_meta
Andrew Geisslereff27472021-10-29 15:35:00 -05009
Patrick Williams03514f12024-04-05 07:04:11 -050010SRC_URI[sha256sum] = "13b205f29251e4f2c66a6c923c31fc4fd780561e03b2d775cff8e4f2915cf947"
11
12PYPI_SRC_URI = "https://files.pythonhosted.org/packages/73/b7/a4df0f93bbdae237e16ba402752151eceee576cbe80c235a2475fbf81eea/paho_mqtt-${PV}.tar.gz"
13
14S = "${WORKDIR}/paho_mqtt-${PV}"
Andrew Geisslereff27472021-10-29 15:35:00 -050015
Patrick Williams39653562024-03-01 08:54:02 -060016DEPENDS += "python3-pytest-runner-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050017
18do_install:append() {
19 install -d -m0755 ${D}${datadir}/${BPN}/examples
20 cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples
21}
22
23PACKAGES =+ "${PN}-examples"
24
Patrick Williams39653562024-03-01 08:54:02 -060025RDEPENDS:${PN}-examples += "${PN} python3-core"
Andrew Geisslereff27472021-10-29 15:35:00 -050026
27FILES:${PN}-examples = "${datadir}/${BPN}/examples"
28
29RDEPENDS:${PN} = "\
Patrick Williams39653562024-03-01 08:54:02 -060030 python3-io \
31 python3-logging \
32 python3-math \
33 python3-netclient \
34 python3-threading \
Andrew Geisslereff27472021-10-29 15:35:00 -050035"
36
37BBCLASSEXTEND = "native nativesdk"