blob: ad45f87ecdb817005e5c2acf6971619ad6ebc2f2 [file] [log] [blame]
SUMMARY = "Light-weight C++ XML Processing Library"
DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \
DOM-like interface with rich traversal/modification capabilities, \
an extremely fast XML parser which constructs the DOM tree from \
n XML file/buffer, and an XPath 1.0 implementation for complex \
data-driven tree queries."
HOMPAGE = "https://pugixml.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=1d569c2ed59c94ddd9586051f8c67da6"
SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
SRC_URI[md5sum] = "7286ee2ed11376b6b780ced19fae0b64"
SRC_URI[sha256sum] = "d156d35b83f680e40fd6412c4455fdd03544339779134617b9b28d19e11fdba6"
inherit cmake
EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=Release \
"