blob: ad45f87ecdb817005e5c2acf6971619ad6ebc2f2 [file] [log] [blame]
Brad Bishop0f291cc2019-09-01 15:16:57 -04001SUMMARY = "Light-weight C++ XML Processing Library"
2DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \
3DOM-like interface with rich traversal/modification capabilities, \
4an extremely fast XML parser which constructs the DOM tree from \
5n XML file/buffer, and an XPath 1.0 implementation for complex \
6data-driven tree queries."
7HOMPAGE = "https://pugixml.org/"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=1d569c2ed59c94ddd9586051f8c67da6"
11
12SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
13SRC_URI[md5sum] = "7286ee2ed11376b6b780ced19fae0b64"
14SRC_URI[sha256sum] = "d156d35b83f680e40fd6412c4455fdd03544339779134617b9b28d19e11fdba6"
15
16inherit cmake
17
18EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON \
19 -DCMAKE_BUILD_TYPE=Release \
20 "