blob: 3c031646b6fc0bdbb3c5b79e75ce8af622015a85 [file] [log] [blame]
SUMMARY = "The Perl Database Interface"
DESCRIPTION = "DBI is a database access Application Programming Interface \
(API) for the Perl Language. The DBI API Specification defines a set \
of functions, variables and conventions that provide a consistent \
database interface independent of the actual database being used. \
"
HOMEPAGE = "http://search.cpan.org/dist/DBI/"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
RDEPENDS_${PN} = " perl-module-carp \
perl-module-exporter \
perl-module-exporter-heavy \
perl-module-dynaloader \
"
LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
SRC_URI[md5sum] = "f2ba18b5cea1c8cb322a62be0a847f3d"
SRC_URI[sha256sum] = "3f2025023a56286cebd15cb495e36ccd9b456c3cc229bf2ce1f69e9ebfc27f5d"
S = "${WORKDIR}/DBI-${PV}"
inherit cpan ptest-perl
do_install_prepend() {
# test requires "-T" (taint) command line option
rm -rf ${B}/t/pod-coverage.t
rm -rf ${B}/t/13taint.t
# source of test failure not obvious
rm -rf ${B}/t/85gofer.t
# unclear why there are several duplicates of tests in tarball
rm -rf ${B}/t/z*.t
}
BBCLASSEXTEND = "native"