blob: 3c031646b6fc0bdbb3c5b79e75ce8af622015a85 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10RDEPENDS_${PN} = " perl-module-carp \
11 perl-module-exporter \
12 perl-module-exporter-heavy \
13 perl-module-dynaloader \
14"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
19SRC_URI[md5sum] = "f2ba18b5cea1c8cb322a62be0a847f3d"
20SRC_URI[sha256sum] = "3f2025023a56286cebd15cb495e36ccd9b456c3cc229bf2ce1f69e9ebfc27f5d"
21
22S = "${WORKDIR}/DBI-${PV}"
23
24inherit cpan ptest-perl
25
26do_install_prepend() {
27 # test requires "-T" (taint) command line option
28 rm -rf ${B}/t/pod-coverage.t
29 rm -rf ${B}/t/13taint.t
30 # source of test failure not obvious
31 rm -rf ${B}/t/85gofer.t
32 # unclear why there are several duplicates of tests in tarball
33 rm -rf ${B}/t/z*.t
34}
35
36BBCLASSEXTEND = "native"