blob: 6642f4b9b1485f3c35d8b9c360fc26d0fc6b2615 [file] [log] [blame]
SUMMARY = "Physical quantities module"
DESCRIPTION = "Physical quantities Python module"
HOMEPAGE = "https://github.com/hgrecco/pint"
SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
PYPI_PACKAGE := "Pint"
inherit pypi ptest setuptools3
SRC_URI[sha256sum] = "f4d0caa713239e6847a7c6eefe2427358566451fe56497d533f21fb590a3f313"
DEPENDS += "python3-setuptools-scm-native"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN} += " \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-packaging \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/testsuite
cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
}