blob: 6642f4b9b1485f3c35d8b9c360fc26d0fc6b2615 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
11inherit pypi ptest setuptools3
12
Andrew Geissler32b11992021-03-31 13:37:05 -050013SRC_URI[sha256sum] = "f4d0caa713239e6847a7c6eefe2427358566451fe56497d533f21fb590a3f313"
Andrew Geissler89770b02020-06-13 10:40:47 -050014
15DEPENDS += "python3-setuptools-scm-native"
16
17BBCLASSEXTEND = "native nativesdk"
18
19SRC_URI += " \
20 file://run-ptest \
21"
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} += " \
Andrew Geissler748a4832020-07-24 16:24:21 -050024 ${PYTHON_PN}-setuptools \
25 ${PYTHON_PN}-packaging \
26"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN}-ptest += " \
Andrew Geissler89770b02020-06-13 10:40:47 -050029 ${PYTHON_PN}-pytest \
30"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/testsuite
34 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
35}