blob: cf7f6f3053d532285f86f7b7210e72ee102b1479 [file] [log] [blame]
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d"
PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/yrutschle/conf2struct"
SRCREV = "6bc9eed1eb50175e5fda791f27d85e72f5a6ac78"
S = "${WORKDIR}/git"
SRC_URI += " \
file://0001-makefile-Add-missing-LDFLAGS.patch \
file://0001-conf2struct-Use-the-right-perl.patch \
"
inherit native
DEPENDS += " \
libconfig-native \
libconfig-perl-native \
"
EXTRA_OEMAKE += " \
DESTDIR=${D} \
prefix=${prefix} \
"
do_compile() {
oe_runmake checker
}
do_install() {
oe_runmake install
}