blob: cf7f6f3053d532285f86f7b7210e72ee102b1479 [file] [log] [blame]
William A. Kennington IIIb2c53062021-02-09 17:48:19 -08001LICENSE = "BSD"
2LIC_FILES_CHKSUM = "file://COPYING;md5=1b886630cdc9a17c26250934beda407d"
3
4PV = "0.1+git${SRCPV}"
5SRC_URI = "git://github.com/yrutschle/conf2struct"
William A. Kennington III32e3f012021-08-05 16:48:56 -07006SRCREV = "6bc9eed1eb50175e5fda791f27d85e72f5a6ac78"
William A. Kennington IIIb2c53062021-02-09 17:48:19 -08007S = "${WORKDIR}/git"
8
9SRC_URI += " \
10 file://0001-makefile-Add-missing-LDFLAGS.patch \
11 file://0001-conf2struct-Use-the-right-perl.patch \
12 "
13
14inherit native
15
16DEPENDS += " \
17 libconfig-native \
18 libconfig-perl-native \
19 "
20
21EXTRA_OEMAKE += " \
22 DESTDIR=${D} \
23 prefix=${prefix} \
24 "
25
26do_compile() {
27 oe_runmake checker
28}
29
30do_install() {
31 oe_runmake install
32}