blob: 101b96d31cd6b868afdfb91e8aa2a87f5e363b96 [file] [log] [blame]
SUMMARY = "File type identification using libmagic"
DESCRIPTION = "This module uses ctypes to access the libmagic file type \
identification library. It makes use of the local magic database and supports \
both textual and MIME-type output."
HOMEPAGE = "http://github.com/ahupp/python-magic"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
PYPI_PACKAGE = "python-magic"
inherit pypi setuptools3
SRC_URI[md5sum] = "5edc6caa39cc62641850f6b1b6f284ba"
SRC_URI[sha256sum] = "b757db2a5289ea3f1ced9e60f072965243ea43a2221430048fd8cacab17be0ce"
RDEPENDS_${PN} += "file \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-io \
${PYTHON_PN}-shell"
BBCLASSEXTEND = "native"