blob: 101b96d31cd6b868afdfb91e8aa2a87f5e363b96 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
9
10PYPI_PACKAGE = "python-magic"
11
12inherit pypi setuptools3
13
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050014SRC_URI[md5sum] = "5edc6caa39cc62641850f6b1b6f284ba"
15SRC_URI[sha256sum] = "b757db2a5289ea3f1ced9e60f072965243ea43a2221430048fd8cacab17be0ce"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
Andrew Geissler5a43b432020-06-13 10:46:56 -050017RDEPENDS_${PN} += "file \
18 ${PYTHON_PN}-ctypes \
19 ${PYTHON_PN}-io \
20 ${PYTHON_PN}-shell"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22BBCLASSEXTEND = "native"