blob: b37801a7f1d5c2e89b7c8c330de8a3848ad53afe [file] [log] [blame]
SUMMARY = "Ampere OEM IPMI commands"
DESCRIPTION = "Ampere OEM IPMI commands"
LICENSE = "Apache-2.0"
S = "${WORKDIR}"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd"
inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
LIBRARY_NAMES = "libzampoemcmds.so"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git;branch=master;protocol=https"
SRCREV = "db24557c2033c5e418104655ddb25e905dcfd6a9"
HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
do_install:append(){
install -d ${D}${includedir}/ampere-ipmi-oem
install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem
}