blob: b37801a7f1d5c2e89b7c8c330de8a3848ad53afe [file] [log] [blame]
Hieu Huynhf3911cd2021-09-24 02:44:10 +00001SUMMARY = "Ampere OEM IPMI commands"
2DESCRIPTION = "Ampere OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5S = "${WORKDIR}"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
Hieu Huynh37f23d82022-08-03 07:16:33 +00009DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd"
Hieu Huynhf3911cd2021-09-24 02:44:10 +000010
Hieu Huynh37f23d82022-08-03 07:16:33 +000011inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
Hieu Huynhf3911cd2021-09-24 02:44:10 +000012
13LIBRARY_NAMES = "libzampoemcmds.so"
14
15S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060016SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git;branch=master;protocol=https"
Andrew Geissler5db570c2022-08-15 09:00:02 -050017SRCREV = "db24557c2033c5e418104655ddb25e905dcfd6a9"
Hieu Huynhf3911cd2021-09-24 02:44:10 +000018
19HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
20NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
21
22FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
24FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
25FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
26
27do_install:append(){
28 install -d ${D}${includedir}/ampere-ipmi-oem
29 install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem
30}