blob: d27e6fce5cd165527f7992e7be596befe2415c53 [file] [log] [blame]
SUMMARY = "The PyPA recommended tool for installing Python packages"
HOMEPAGE = "https://pypi.python.org/pypi/pip"
SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
DEPENDS += "python3 python3-setuptools-native"
SRC_URI[md5sum] = "1aaaf90fbafc50e7ba1e66ffceb00960"
SRC_URI[sha256sum] = "21207d76c1031e517668898a6b46a9fb1501c7a4710ef5dfd6a40ad9e6757ea7"
inherit pypi distutils3
do_install_append() {
# Install as pip3 and leave pip2 as default
rm ${D}/${bindir}/pip
}
RDEPENDS_${PN} = "\
python3-compile \
python3-io \
python3-html \
python3-json \
python3-netserver \
python3-setuptools \
python3-unixadmin \
python3-xmlrpc \
python3-pickle \
"
BBCLASSEXTEND = "native nativesdk"