blob: d27e6fce5cd165527f7992e7be596befe2415c53 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
Brad Bishop64c979e2019-11-04 13:55:29 -05009SRC_URI[md5sum] = "1aaaf90fbafc50e7ba1e66ffceb00960"
10SRC_URI[sha256sum] = "21207d76c1031e517668898a6b46a9fb1501c7a4710ef5dfd6a40ad9e6757ea7"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
Brad Bishop00e122a2019-10-05 11:10:57 -040028 python3-pickle \
Brad Bishopc342db32019-05-15 21:57:59 -040029"
30
31BBCLASSEXTEND = "native nativesdk"