blob: 3786ccb855537788eed76107e9a2b52cd4077155 [file] [log] [blame]
SUMMARY = "Run-time type checker for Python"
HOMEPAGE = "https://pypi.org/project/typeguard/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
SRC_URI[md5sum] = "411df8eefd76ffa014328a46342bdf38"
SRC_URI[sha256sum] = "529ef3d88189cc457f4340388028412f71be8091c2c943465146d4170fb67288"
inherit pypi setuptools3 ptest
SRC_URI += " \
file://run-ptest \
"
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
${PYTHON_PN}-typing-extensions \
${PYTHON_PN}-unixadmin \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
DEPENDS += "\
python3-distutils-extra-native \
python3-setuptools-scm-native \
"
RDEPENDS_${PN} += "python3-typing"
BBCLASSEXTEND = "native nativesdk"