blob: 3786ccb855537788eed76107e9a2b52cd4077155 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
Andrew Geisslerc87764f2020-06-27 00:16:32 -05006SRC_URI[md5sum] = "411df8eefd76ffa014328a46342bdf38"
7SRC_URI[sha256sum] = "529ef3d88189cc457f4340388028412f71be8091c2c943465146d4170fb67288"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
Andrew Geissler748a4832020-07-24 16:24:21 -05009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-typing-extensions \
18 ${PYTHON_PN}-unixadmin \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26DEPENDS += "\
27 python3-distutils-extra-native \
28 python3-setuptools-scm-native \
29"
30
31RDEPENDS_${PN} += "python3-typing"
32
33BBCLASSEXTEND = "native nativesdk"