blob: 89beaa91499bb9b9b8eb1e8cfe0c67362d78dfb9 [file] [log] [blame]
PACKAGECONFIG:append:s6q = " sync-mac nic-ethtool"
FILES:${PN}:append:s6q = " ${datadir}/network/config.json"
do_install:append:s6q() {
install -d ${D}${datadir}/network/
if ${@bb.utils.contains('MACHINE_FEATURES', 'bonding', 'true', 'false', d)};
then
echo '{"bond0":"bmc","eth0":"bmc","eth1":"bmc"}' \
> ${D}${datadir}/network/config.json
else
echo '{"eth0":"bmc"}' > ${D}${datadir}/network/config.json
fi
}